Regresar   Foro de marcianitos.org > Emuladores y programas de todo tipo > Sistemas operativos > MS-DOS

 
 
Old 14-ago-2008, 22:12   #1
Aioros
Editor Marciano
Arcados y sonido AC97 por fin funcionando

Bubu sacando un nuevo S.O. (el ArcadeXP) y yo aquí a vueltas con el "antiguo" (con todo el cariño ).

Decir en primer lugar que me he pasado casi 2 semanas (sin exagerar) intentando que el tinglado funcionase, mas concretamente que el tinglado "sonase" , pero no había manera . Finalmente, cuando me encontraba al borde del colapso, se hizo la luz y ¿voila!, ArcaDOS funcionando 100%.

Instalar y configurar el ArcaDOS para usarlo con un monitor de PC también ha tenido su dificultad, pero nada que no se pudiese solucionar en una tarde y aplicando unas ligeras dosis de paciencia y formateos . Sin embargo el sonido ha sido "harina de otro costal".

Aquí ha estado el principal escollo. En principio, el sonido integrado en la placa base (AC'97) no debería dar problemas, pero lo cierto es que los da (y muchos). Despues de muchos ajustes, activaciones y desactivaciones en la bios, y quebraderos de cabeza varios, decidí tirar de la SoundBlaster PCI 128 que usaba con Windows.
Me las prometía felices, pero ni así. Que conste que he seguido todos los pasos relatados en los diferentes hilos y posts al respecto, pero me ha sido imposible hacerla funcionar con el ArcaDOS. Con otros programas, como juegos abandonware bajo DOS, funciona de lujo, pero con el AdvMenu y el AdvMame provoca el cuelgue del ordenador.

Resignado ya a no poder instalar ArcaDOS, me jugué la última carta a hacer funcionar como Dios manda el sonido integrado en la placa. Esta es:

Code:
kinetiZ 7T Via Apollo kt-133
Chip de Audio: vt82c686a
Direct sound AC97 Audio
AC97 2.1
He buscado drivers para sonido AC'97 por Internet adelante, pero sin resultados positivos...hasta ahora (es lo que tiene no saber el nombre concreto de los archivos que se busca ).

En una versión de Ms-DOS que tenía por aquí (la 7.1 mas concretamente) había una carpeta llamada "ADDONS". En ella, diversos drivers para hacer funcionar tarjetas de sonido bajo MS-DOS.

Code:
 [.] Sound Blaster AWE PnP
 [.] Sound Blaster PCI
 [.] Sound Blaster Live!
 [.] ESS ISA 688/1688
 [.] VIA AC97
 [.] C-Media AC97
Los archivos que me podían interesar eran los relativos al chip VIA AC97, llamados:

Code:
Viafmtsr.com
Viaudio.com
Colocandolos en la carpeta "Arca2snd" del ArcaDOS (valdría también en "dos") y modificando el Autoexec.bat........

Code:
c:\arcados\arca2snd\viaudio.com
c:\arcados\arca2snd\viafmtsr.com
set blaster=a220 i5 d1 p330
ECHO OFF
CLS
C:\DOS\SMARTDRV /X /Q
C:\DOS\KEYB SP,,C:\DOS\KEYBOARD.SYS
CD C:\ARCADOS\ADVMENU
IF NOT EXIST ADVMENU.RC2 COPY ADVMENU.RC ADVMENU.RC2
COPY /Y ADVMENU.RC2 ADVMENU.RC
PATH C:\DOS
CALL C:\CDROM.BAT
CD C:\ARCADOS\ADVMENU
ADVMENU
........¡¡funciona!!

Sería interesante saber si, tanto éstos como el resto de drivers, serían útiles para solucionar los problemas que genera el sonido integrado con ArcaDOS.

No se si se podrá subir el archivo en cuestión, pero buscando en San Google no es dificil encontrarlos (ahora que se sabe su nombre es muy sencillo). Si no hay inconveniente dadme un toque y lo subo.

Edito:

Placas con sonido AC'97 funcionando:

Aioros:

Code:
kinetiZ 7T Via Apollo kt-133
Chip de Audio: vt82c686a
Direct sound AC97 Audio
AC97 2.1
Drivers necesarios:
 Viafmtsr.com
Viaudio.com

Daesdae:

Code:
Sonido integrado 5.1 channels AC'97 Audio
Placa base (madre): ASRock P4V88
Bios: AMI BIOS
Chipsets: South Bridge, segun manual -> VIA VT8237 en el chip pone VT8237R
La bios solo tiene la opcion de activar o desactivar el sonido, nada de
SoundBlaster ni parecido y funciona sin drivers, tan solo poniendo en
los rc vsync/ac97 o vsync/sb
Placas con sonido AC'97 que no funcionan:

Pakoman

Code:
848p Neo MSI-6788 Ver.1 (al menos sin drivers de msdos de ac97, que tampoco los he encontrado)
AC' 97 link controller integrated in ICH5
6 channels software audio codec ALC655
- Compliance with AC97 v2.2 Spec
- Meet PC2001 audio performance requirement
La bios es AMI 3.31a, y en las opciones solo pone "AC97 Auto/Disabled".
Tiene chipset AC97 de Realtek ALC655, pero no se si tendrá ese chip de sound blaster en la placa, creo que no.
P4VXASD2 V1.1a - ECS Elitegroup http://www.motherboard.cz/mb/ecs/P4VXASD2V1X.htm
La placa tiene chipset VIA.
AC97 Audio Codec: Compliant with AC97 2.2 specification.
Sin opciones de Sound Blaster en la bios, solo AC97 enable/disable, y el puerto midi.
No suena nada.
Investigando un poco he visto que tiene chip sonido Realtek ALC101 2-channel audio CODEC, Compliant with AC'97 2.2 specification.
Los drivers de la pagina oficial no me funcionan tampoco

Editado por Aioros en 02-feb-2009 a las 17:28. Razón: Añadidas las placas base que funcionan con o sin drivers
Old 15-ago-2008, 01:15   #2
Bubu
Editor Marciano
Mi enhorabuena personal, Aioros ¡¡¡ Muuuuy bien !!! Me ha encantado que no te rindieras, y sobre todo, que lo hayas contado aquí tan bien, con tanto detalle y tan científicamente. De verdad, un 10. Efestiviwonder el sonido es uno de los mayores poblemas de ArcaDOS (el único, díríra yo) pero con descubrimientos así es como realmente el producto avanza.
Me encantaría poder subir tu mensaje anterior, casi tal y como está, al tutorial de ArcaDOS. Espero contar con tun permiso.

También me hubiera gustado verte en una afoto el careto de emoción cuando aquello sonó por primera vez, después de tantísimos días de prueba.

¡¡¡ E N H O R A B U E N A !!!



EDITO: Un par de preguntas -> ¿El CONFIG.SYS no cambia? ¿Y los RC, siguen siendo device_audio vsync/ac97 ?
Old 15-ago-2008, 17:50   #3
Aioros
Editor Marciano
Por supuesto que tienes mi permiso, faltaría mas . Es todo un honor .

No tenía a mano la cámara de fotos en ese momento, pero te garantizo que los vecinos se tienen que estar acordando de mi .

Respecto a los archivos, el config.sys no hizo falta modificarlo y en los RC puse device_sound auto.

He de decir que en la bios tengo una opción para el sonido integrado AC97 que es "sound blaster emulation" que he activado. Lo que no comprobé es si cambiando device_sound auto por device_sound vsync/ac97 seguirá funcionando.
El ordenador con ArcaDOS lo tengo en casa de mis padres y hasta el lunes no podré pasarme por allí, pero lo comprobaré.

Por cierto, si vas a modificar el tuto del ArcaDOS convendría que incluyeses algunos cambios:

Code:
1-
Si tienes el disco duro particionado (C:, D: y E: por ejemplo)
la copia de archivos falla pues el instalador espera que D: sea la unidad de CD.
Al ser D: una partición da un mensaje de error.
Una vez que se instala todo ya se puede crear una partición extendida, pero
no antes.
2-
Despues del paso 1 (crear partición primaria) hay que reiniciar el equipo.
En mi caso he comprobado que si modifico el tamaño de la partición primaria
y despues prosigo con el paso 2, el formateo no me reconoce el cambio de
tamaño. Para que la modificación surta efecto es necesario reiniciar antes de
seguir con el paso 2.
3-
Despues del paso 2 (formateo) también es necesario reiniciar el equipo.
De no hacerlo la copia de archivos del paso 3 falla.
Por último, y al margen del ArcaDOS, para manejar los archivos dentro de DOS cuando no tienes la posibilidad de pinchar el disco duro en otro ordenador (para copiar las roms, snaps, etc) es muy útil el programa abandonware "Norton Commander".
Es muy similar al "Total Commander" (antiguamente llamado "windows commander"). Es lento (funciona bajo DOS), pero a falta de pan....
Además, para moverse mejor con él, es recomendable activar el ratón en el inicio de DOS. Para ello hay que seguir los siguientes pasos:

Code:
1-
Copiar en la carpeta DOS los archivos mouse.com y mouse.sys de una versión
cualquiera de DOS. Habría que probar también con el ctmousep.com que trae
el Advmame (en la ruta arcados\mameemul\contrib\optimous).
Si funciona sería perfecto.
2-
Modificar el autoexec.bat con una línea más:
c:\dos\mouse.com
Es preferible ponerla al principio para que no interfiera con el marcianito
que sale como imagen de carga.
Copiando el programa en una carpeta cualquiera de c: y ejecutándolo tenemos un gestor de archivos muy cómodo.

En cuanto pueda, sigo con las pruebas (Tengo que catar algunos drivers para USB que, según dicen por ahí, es posible que funcionen).
Old 16-ago-2008, 00:14   #4
Bubu
Editor Marciano
Perfect, Aioros, la prueba del device_sound me interesa mucho. Ojalá funciona con vsync/ac97, y así hay que tocar menos cosas.
Respecto a tus 3 anotaciones, para la primera (el tema de las letras de unidad) decirte que en el BAT de instalación (creo que MENU.BAT) viene una variable llamada CD que vale D: Bastaría con editar ese BAT y cambiarle la letra que sea, lo mismo para el disco durro: la variable HD la puedes igualar a G: por si tu disco duro está en G.
Respecto a las anotaciones sobre el reinicio, nu lo sabía. Mía que hi hecho pruebas, pero lo cierto es que muchos usuarios me han reportado cosas por el estilo. Lo incluiré en el tutorial. Nunca está de más un bonito reinicio. ;-)
Old 16-ago-2008, 00:18   #5
Bubu
Editor Marciano
Ay, se me olvidaba una cosa: este invento puede ser la puerta que abra al ArcaDOS todos los emuladores bajo placas con sonido integrado: NES, SNES, GBA, etc.
Habrá que empezar a sacar plugins, jiji
Old 16-ago-2008, 15:52   #6
Aioros
Editor Marciano
Quote:
Originalmente publicado por Bubu Ver post
Respecto a tus 3 anotaciones, para la primera (el tema de las letras de unidad) decirte que en el BAT de instalación (creo que MENU.BAT) viene una variable llamada CD que vale D: Bastaría con editar ese BAT y cambiarle la letra que sea, lo mismo para el disco durro: la variable HD la puedes igualar a G: por si tu disco duro está en G.
Editando el archivo ARCA2SYS.ima, al principio se hace referencia al menu.bat que mencionas, pero no lo encuentro.
De todos modos, mas abajo, en la parte del paso tres bastaría con modificar la línea en negrita, ¿no?:

Code:
:MENU3
CLS
ECHO.
ECHO.
ECHO.
ECHO        MENU DE INSTALACION   [ ARCADOS 1.1 ]
ECHO        =====================================
ECHO.
ECHO.
ECHO        PASO 3/3 : INSTALACION DE ARCADOS
ECHO.
ECHO.
ECHO.
ECHO        ELIJA UNA DE LAS SIGUIENTES OPCIONES:
ECHO.
ECHO.
ECHO.
ECHO.
ECHO        (1)   INSTALAR ARCADOS
ECHO.
ECHO        (2)   SALIR
ECHO.
ECHO.
ECHO.
ECHO.
ECHO.
CHOICE /C:12 /N PULSE 1 o 2: 
IF ERRORLEVEL == 2 GOTO FIN
IF ERRORLEVEL == 1 GOTO ARCADOS
GOTO FIN
:ARCADOS
CLS
XCOPY /E D:\FILES\*.* %RAIZ%\   ----> Cambiando "D:" por la letra de la 
unidad de CD
PAUSE
GOTO FIN
En cuanto pueda hago la prueba con el sonido
Old 16-ago-2008, 15:58   #7
Fuents
Administrador
 
Avatar de Fuents
Bubu, yo lo que haría es forzar una letra en el cdrom (por ejemplo la M: ) y así no tendrás problemas de si el equipo tiene varios lectores, discos duros, etc....

La cosa seria algo asi...

MSCDEX /D:MSCD001 /L:M: Lo que no recuerdo es si la M: debía acabar con los : o se ponía la M a pelo... (eso sería siempre y cuando en el config le hubieses puesto MSCD001 como nombre al CDROM)
Old 16-ago-2008, 16:21   #8
Bubu
Editor Marciano
OK, buena idea, Fuents, esto lo incluiré también en ArcaDOS 1.2, jiji
Espero incluir en ese 1.2 algún que otro sistema, nu sé, ¿NES? ¿SNES? ¿GBC? ¿GBA?...
Old 16-ago-2008, 16:23   #9
Fuents
Administrador
 
Avatar de Fuents
Hombre... NES y SNES de cajón... los otros 2 como opcionales no estaría nada mal.. .
Old 16-ago-2008, 16:25   #10
Bubu
Editor Marciano
Para perfeccionar eso nos quedaría por investigar si pinchando un mando NES a un adaptador NES-USB (que los venden mu baratos por ahí) y pinchando el USB al MSDOS se puede instalar algún pograma que mapee el USB a pulsaciones de teclado... Pero por no ensuciar este hilo, lo dejaré para otro moméneto.
 

Tags
arcados;sonido